QGIS

Da GolemWiki.

INTRODUZIONE

Introduzione alla guida

Questa guida vuole essere un un primo passo verso la conoscenza e l'utilizzo di QGIS, un ottimo programma desktop per la gestione dei dati geografici digitali. Il progetto QGIS e il suo team di sviluppo, rappresentano un bel' esempio di come il software libero possa sostituire, ma anche risultare migliore di programmi commerciali, spesso ritenuti killer application.

La guida si rivolge sia a chi si muove per la prima volta nel mondo GIS, sia a chi vuole abbandonare una soluzione commerciale o semplicemente provare una nuova strada nel mondo del software libero. Nel secondo caso studenti, tecnici, liberi professionisti e chiunque altro potrà qui trovare utili informazioni per l'installazione e su come muovere i primi passi dentro un programma, che inizialmente potrà risultare "difficile", semplicemente perché diverso.

Nella guida si troveranno passaggi e procedure ripresi da altri tutorial presenti in rete, ma nel rispetto della sezione Pagine arancioni del GOLEM che la ospita, saranno inserite solo quelle realmente testate da chi scrive.


Introduzione a QGIS

Quantum GIS, o per gli amici QGIS, è un GIS (Geographic Information System) sotto licenza GNU General Public License. QGIS è multi piattaforma e gestisce molti formati raster vettoriali e database. È un software veloce nell'esecuzione e nella gestione dei dati, la sua interfaccia è intuitiva e grazie al suo continuo sviluppo mette a disposizione dell'utente un applicazione sempre piu stabile e completa.

INSTALLAZIONE

Per l'installazione si consiglia di utilizzare la versione più aggiornata di QGIS. I sistemi operativi più testati sono sicuramente Linux Debian e le distribuzioni basate su Debian come Ubuntu. Per i sistemi commerciali quello forse più testato è Windows. Per tutti i sistemi operativi si consiglia l'installazione 64 bit, in quanto riesce a gestire ed esportare raster di grandi dimensioni. Esistono 2 versioni correnti di Qgis, la LTR (long Term Release) i cui aggiornamenti sono indirizzati al solo bugfix e viene mantenuta più a lungo e la normale release contente le nuove funzioni e di più breve rilascio. La prima è indicata ad esempio per le pubbliche amministrazioni, mentre la seconda per chi vuol sperimentare le nuove funzioni.


Linux (Ubuntu 10.04, 10.10 e 12.04)

Per Linux verranno esposte due modalità di installazione riguardanti Ubuntu 10.04 (Lucid Lynx - Long Term Support) 32 bit testate anche su Ubuntu 10.10 Maverick Meerkat. Il primo metodo è il più semplice e basta aggiungere la riga del repository (server da cui scaricare QGIS) al file di configurazione di APT (il gestore dei pacchetti Debian) ed installarlo, il secondo metodo è un po più complesso, ma permette di gestire formati chiusi come ECW o più semplicemente di poter installare l'ultima versione in sviluppo. Le due installazioni (da repository e da sorgente) possono convivere nello stesso sistema.


Installazione da repository

L'aggiunta dei repository e l'installazione di QGIS può esser fatta completamente tramite interfaccia grafica mediante Synaptic Sistema--> Amministrazione--> Gestione Pacchetti" dal menù "impostazioni--> repository". Per comodità e maggior semplicità verrà spiegata la procedura da linea di comando. E' necessario che il pc sia connesso ad internet. E' possibile visualizzare i repository unstable di Ubuntugis cliccando su Technical details about this PPA della pagina web dedicata e scegliere la distribuzione che utilizziamo, nel nostro caso "Lucid".

Per aggiungere i repository ed installare QGIS apriamo un terminale (Applicazioni--> Accessori--> Terminale) e digitiamo (va bene anche copia e incolla dal sito) i comandi che seguono, premendo invio ogni volta e rispondendo alle domande che il terminale ci pone (password di amministratore, risposte affermative per l'installazione).

sudo su

(fa diventare momentaneamente amministratori)

add-apt-repository ppa:ubuntugis/ubuntugis-unstable

(aggiunge i repository al file /etc/apt/source.list e scarica la chiave pubblica)

apt-get update

(aggiorna la lista dei pacchetti dopo l'aggiunta dei nuovi repository)

apt-get install qgis python-qgis

(installa qgis e python-qgis necessario alla gestione dei plugin e tutte le loro dipendenze compreso GRASS)

Adesso si può avviare il programma digitando da terminale qgis oppure dall'icona nel menù "Applicazioni-->Scienza-->QGIS . In caso di uscita di una nuova versione il programma si aggiornerà insieme al sistema.


NEW: ABILITARE ECW DA REPOSITORY

Questo è un metodo molto veloce rispetto a quello che viene spiegato nella sezione sottostante e che è stato messo a punto grazie ai suggerimenti raccolti nella mailinglist di GFOSS. In pratica si tratta di installare le librerie gdal che supportano ecw direttamente grazie a sorgenti gia preparati ed installare solo i driver ecw mediante compilazione. Questo metodo è stato testato efficacemente su ubuntu 10.04 e 12.04 ed è possibile solo grazie al lavoro del team di Ubuntugis.

Installare dai repository ubuntugis-unstable (seguendo le indicazioni sovrastanti) i sorgenti di libgdal-ecw-src e gia che ci siamo installiamo anche checkinstall che ci servirà durante la compilazione per creare un pacchetto deb, quindi più semplice da gestire.

sudo apt-get install libgdal-ecw-src checkinstall

Dopo si deve scaricare la libreria libecwj2-3.3 (funziona con la libecwj2-3.3.20060906) dal sito

maptools . Vi consiglio di farvi una copia di questa libreria dato che come tutti i software non liberi non sempre sono semplici da trovare e vi potrà tornare utile nel caso doveste ripetere la procedura ad un aggiornamento di Qgis.

Dopo entrate nella cartella della libreria appena scaricata

cd /home/vostroutente/Scaricati/
tar xzf libecwj2-3.3.20060906.tar.gz 
cd ./libecwj2-3.3.20060906/

A questo punto iniziamo la compilazione

./configure --prefix=/usr
make

(compila il sorgente. Ci vorrà qualche minuto, ma la compilazione si dimezza con processori recenti con l'opzione make -j2 su processori con 2 core o thread,oppure aumentando la cifra in base al numero di core o thread in possesso della nostra macchina e che vogliamo assegnare alla compilazione)

sudo checkinstall

(rispondete alle domande che vi pone checkinstall)

gdal-ecw-build /usr

Fine dell'installazione, in pochi minuti abbiamo installati i driver ecw per qgis su ubuntu. in caso di aggiornamento di Qgis ripetete l'operazione.


Installazione da sorgenti

L'installazione di QGIS dai sorgenti può essere molto utile se si vuole l'ultima versione in sviluppo per delle funzionalità appena introdotte, oppure se si ha bisogno di lavorare con dei formati chiusi come file .ecw o .dwg che per motivi di licenza di distribuzione non sono inseriti direttamente nei programmi dei repository. L'installazione tramite sorgenti deve essere eseguita seguendo un percorso preciso, ovvero si deve installare i seguenti sorgenti uno dopo l'altro nel seguente ordine (tralasciando le dipendenze necessarie) : il Codec proprietario --> libreria GDAL --> GRASS --> libreria GDAL-GRASS --> QGIS . Una volta fatta per intero la procedura se si ha solo bisogno di aggiornare QGIS basterà installare la nuova versione senza installare di nuovo quelli prima. Questa guida è stata presa da Instalar Grass e QGis no Ubuntu 9.10 (com ECW e MrSID) Come abilitare il supporto ai file ECW in GDAL e visualizzarli in GRASS e QGIS gdal-ecw delle ottime guide adatte allo scopo. Nella guida si fa riferimento all'installazione del codec ECW, questo perchè purtroppo molte pubbliche amministrazioni, nonostante le direttive europee e regionali continuano a distribuire (con licenze restrittive e a pagamento) dati esclusivamente in formati proprietari, come ad esempio le ortofoto in ecw. Di conseguenza è necessario aggiungere dei driver non liberi a QGIS per leggere tali dati. Nel caso non serva tale driver per ecw basta saltare il primo passaggio della guida. Per i dwg il problema si complica. Una strada è quella di scaricare la libreria opendwg non open source dal sito http://www.opendesign.com/ . Per far questo bisogna richiedere la password in maniera molto macchinosa inviando per posta o fax la domanda che trovate su http://www.opendesign.com/members . Se si è studenti la richiesta è gratis altrimenti si deve diventare associati pagando una quota. Se non avete tempo o voglia di seguire questa procedura potete usare il loro convertitore (non open source) EveryDWG sotto wine per convertire dwg in dxf (la procedura funziona ma per adesso molto lenta) oppure aprire i file dwg con GVsig ed esportarli in .shp . Gvsig è un buon gis open che gira su java, molto simile nelle impostazioni ad altri programmi commerciali. In futuro speriamo di poter utilizzare e quindi scrivere una guida su GDAL+ LibreDWG. Se invece cercate un programma (freeware) cad che vi aiuti con i dwg, potete provare intanto draftsight con wine aspettando che esca la versione per linux

Preparazione spazio di lavoro

Tutte le operazioni (o quasi) verranno eseguite da terminale. Si dovrà rispondere alle varie domande che pone il terminale, come ad esempio password di amministratore o risposta affermativa in caso di installazione di dipendenze. Si può utilizzare il tasto tab per il completamento dei percorsi e dei nomi di file. Le procedura standard di installazione di un sorgente in linux rimane ./configure --> make --> make install Da Ubuntu andare su Applicazioni--> Accessori --> Terminale e prepariamoci lo spazio di lavoro, semplicemente una cartella temporanea dove installare ed eseguire le compilazioni.

mkdir ./tmp

(crea una cartella dal nome tmp dentro la vostra home, quindi se il vostro utente si chiama pippo avrete /home/pippo/tmp )

cd ./tmp

(per spostarci dentro la cartella appena creata)


Installare il software necessario alla compilazione

da terminale:

sudo apt-get install build-essential g++ subversion


Installare il codec ecw

Attualmente non conosco la procedura esatta per scaricare il sorgente del codec ecw (versione 4.1), registrandosi sul sito della erdas si riceve solo il binario per windows ECW JPEG2000 Codec SDK, probabilemente mandando una mail al responsabile si riesce ad avere i sorgenti a noi necessari. Per l'aggiornamento di questa guida ho utilizzato la vecchia versione che ormai tengo ben stretta (purtroppo con il software chiuso succede anche questo!!! chi trova una soluzione aggiorni pure questa sezione). Scompattare il file dentro la nostra cartella /tmp

unzip /home/pippo/Scaricati/ecw_jpeg_2000_sdk_3_3_source.zip

(scompatta il file zip dentro la cartella dove siamo, ovvero /home/pippo/tmp)

unzip ./ImageCompressionSDKSourceCode3.3Setup_20070509.zip

(scompatta il file zip e crea la cartella libecwj2-3.3 le cifre 3.3 e 20070509 si riferiscono alla versione scaricata)

cd ./libecwj2-3.3

(si sposta dentro la cartella dei sorgenti del codec ecw)

./configure --prefix=/usr

(Prepara la configurazione per la compilazione)

make

(compila il sorgente. Ci vorrà qualche minuto, ma la compilazione si dimezza con processori recenti con l'opzione make -j2 su processori con 2 core o thread,oppure aumentando la cifra in base al numero di core o thread in possesso della nostra macchina e che vogliamo assegnare alla compilazione)

sudo make install

(diventa amministratore ed installa il sorgente)

cd ..

(torna al livello superiore)

Installare la libreria GDAL
svn checkout https://svn.osgeo.org/gdal/trunk/gdal gdal

(scarica l'ultima versione della libreria GDAL)

cd ./gdal

(sposta nella cartella di GDAL)

./configure --without-grass  --with-ecw=/usr

(prepara il codice sorgente alla compilazione)

Dopo la configurazione vi deve uscire un output del genere:

...
GRASS support:             no
...
...
ECW support:               yes		
...
make

(compila il sorgente. Ci vorrà qualche minuto, ma la compilazione si dimezza con processori recenti con l'opzione make -j2 su processori con 2 core o thread,oppure aumentando la cifra in base al numero di core o thread in possesso della nostra macchina e che vogliamo assegnare alla compilazione)

sudo make install

(diventa amministratore ed installa il sorgente)

sudo ldconfig

(riconfigura link dinamici delle librerie)

gdalinfo --formats

(verifica la corretta installazione di GDAL e il supporto a tutti ai vari formati ecw compreso)

cd ..

(torna al livello superiore)


Installare GRASS

Scaricare l'ultima versione stabile di GRASS, ad esempio la 6.4.1RC1 .

tar xzf /home/pippo/Scaricati/grass-6.4.1RC1.tar.gz

(scompatta grass nella nostra cartella di lavoro)

sudo apt-get install flex bison libreadline5-dev libncurses5-dev lesstif2-dev debhelper \
dpatch libtiff4-dev tcl8.5-dev tk8.5-dev fftw-dev xlibmesa-gl-dev libfreetype6-dev \
autoconf autotools-dev libgdal1-dev proj libjpeg62-dev libpng12-dev libpq-dev \
unixodbc-dev doxygen fakeroot cmake python-dev python-qt4-dev python-sip4 python-dev \
sip4 libglew1.5-dev libxmu-dev libqt4-dev libgsl0-dev swig pyqt4-dev-tools cmake-curses-gui

(installa le componenti necessarie alla compilazione ed installazione di GRASS. ATTENZIONE a copiare tutta la stringa e alle versioni dei programmi nel caso in cui siano state aggiornate)

cd grass-6.4.1RC1

(entra nella cartella di GRASS)

./configure --with-tcltk-includes=/usr/include/tcl8.5 \
--with-proj-share=/usr/share/proj --with-gdal=/usr/local/bin/gdal-config \
--with-python=/usr/bin/python2.6-config

(prepara il codice sorgente alla compilazione)

make

(compila il sorgente. Ci vorrà qualche minuto, ma la compilazione si dimezza con processori recenti con l'opzione make -j2 su processori con 2 core o thread,oppure aumentando la cifra in base al numero di core o thread in possesso della nostra macchina e che vogliamo assegnare alla compilazione)

sudo make install

(diventa amministratore ed installa il sorgente)

cd ..

(torna al livello superiore)

Installare la libreria GDAL-GRASS

Per prima cosa creiamo un file di configurazione (grass.conf) contente il percorso della libreria grass appena installata.

sudo gedit /etc/ld.so.conf.d/grass.conf

(apre l'editor di testo gedit per creare da amministratore il file grass.conf nella cartella /etc/ld.so.conf.d/)

/usr/local/grass-6.4.1RC1/lib/

(percorso da scrivere dentro il file, salvare e chiudere l'editor)

Adesso scarichiamo il codice sorgente della libreria GDAL. Ad esempio attualmente l'ultima versione è la grass-1.4.3.

tar xzf /home/pippo/Scaricati/gdal-grass-1.4.3.tar.gz

(scompatta gdal-grass nella nostra cartella di lavoro)

cd ./gdal-grass-1.4.3

(entra nella cartella appena scompattata)

./configure --with-grass=/usr/local/grass-6.4.1RC1

(configura la libreria per la compilazione)

make

(compila il sorgente. Ci vorrà qualche minuto, ma la compilazione si dimezza con processori recenti con l'opzione make -j2 su processori con 2 core o thread,oppure aumentando la cifra in base al numero di core o thread in possesso della nostra macchina e che vogliamo assegnare alla compilazione)

sudo make install

(diventa amministratore ed installa il sorgente)

sudo ldconfig

(riconfigura link dinamici delle librerie)

gdalinfo --formats

(verifica la corretta installazione di GDAL e il supporto a tutti ai vari formati ecw compreso)

cd ..

(torna al livello superiore)


Installare QGIS
sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable

(aggiunge i repository al file /etc/apt/source.list e scarica la chiave pubblica)

sudo apt-get update

(aggiorna la lista dei pacchetti)

sudo apt-get build-dep qgis

(controlla le dipendenze per compilare QGIS)

Questa è l'ultima fase dell'installazione e può essere ripetuta più volte a distanza di tempo per poter usufruire delle ultime novità di QGIS

svn co https://svn.osgeo.org/qgis/trunk/qgis qgis_unstable

(scarica da internet l'ultima versione di sviluppo di QGIS, oppure svn co https://svn.osgeo.org/qgis/trunk/qgis qgis_current per la versione stabile)

cd ./qgis_unstable

(entra nella cartella)

ccmake .

(per accedere manualmente alla configurazione)

Accediamo all'interfaccia di testo per la configurazione di ccmake premendo C scorriamo fino alla riga GRASS_PREFIX premiamo invio per attivare l'editazione ed aggiungiamo il percorso /usr/local/grass-6.4.1RC1 . Apparirà così:

GRASS_PREFIX                     /usr/local/grass-6.4.1RC1

Premiamo C per ripetere la configurazione che adesso avrà il percorso di GRASS e dopo premiamo G per avviare la configurazione ed uscire. Nel caso in cui stiate ripetendo l'operazione successiva per aggiornare nuovamente qgis e ccmake vi restituisce un errore di dipendenza non trovata, vi consiglio di ripetere il comando sudo apt-get build-dep qgis .

make

(compila il sorgente. Ci vorrà qualche minuto, ma la compilazione si dimezza con processori recenti con l'opzione make -j2 su processori con 2 core o thread,oppure aumentando la cifra in base al numero di core o thread in possesso della nostra macchina e che vogliamo assegnare alla compilazione)

sudo make install

(diventa amministratore ed installa il sorgente)

Adesso QGIS è installato, premete da terminale

qgis

Per avviarlo oppure create un link sul desktop o sul menù (trovate le icone in /usr/local/share/qgis/images/icons) . Adesso è possibile cancellare la cartella di lavoro /tmp dentro la nostra home, anche se è consigliabile salvare i driver non liberi visto che non si è mai certi della loro disponibilità. Inoltre nel caso in cui vogliate provare gli aggiornamenti della versione di sviluppo giorno per giorno, vi consiglio di non cancellare la cartella del download svn di QGIS. Cosi facendo risparmierete tempo nel download e nella compilazione, infatti vi basterà lanciare un make (o make -j2) e dopo un sudo make install per aggiornare QGIS.


Windows

Per i Sistemi windows le principali modalità d'installazione sono due, per entrambe si deve fare riferimento a alla pagina ufficiale dei download di QGIS di cui si consiglia la versione corrente. Vi è una modalità "classica" in cui si scarica un eseguibile che installerà il programma oppure un altro metodo che utilizza OSGeo4W, un installatore di programmi gis liberi per windows. Questo sistema di gestione dei pacchetti in stile distribuzione Linux, rende più facile l'installazione di altri programmi gis liberi oltre a QGIS, come GRASS, UDIG e l'aggiornamento di questi.


Installazione standalone

Scaricare sul proprio computer la versione Windows - Standalone e seguire la procedura d'installazione. Questa versione conterrà i plugin di grass, ma non Grass il quale deve essere installato a parte dal portale di riferimento.


Installazione da OSGeo4W

Per attivare la lettura dei file ecw prima si deve scaricare e installare il nuovo sdk (settembre 2010), installarlo, e dopo copiare le ridistibutable dll (a 32bit) in windows\system32. Dopodichè si procede alla normale installazione. Scaricare il piccolo eseguibile dalla pagina del progetto OSGeo4W e procedere con l'installazione avanzata (Advanced Install). E' possibile scegliere altre due opzioni, che possono tornare utili nel caso si debba installare su diversi computer gli stessi programmi, ovvero Download Without Installing, che scarica i pacchetti dentro una cartella temporanea e Install from Local Directory, che installa i pacchetti scaricati con l'opzione precedente. Dopo aver scelto Install from Internet scegliere "avanti" e lasciare cosi come sono le successive richieste per le cartelle d'installazione e connessione internet. Dopo che il programma si sarà sincronizzato con i server si aprirà la finestra per la selezione dei pacchetti. In alto a destra si può scegliere la versione dei pacchetti, in questo caso lasciamo spuntato "Current". Aprire la sezione Desktop e cliccare più volte per scegliere la versione scelta nella colonna "New", nel nostro caso scegliere qgis-unstable: Quantum GIS . Nella sezione Libs è possibile scegliere delle librerie utili al nostro caso oltre a quelle di Default come ad esempio gdal-ecw o le librerie python. Dopo di che il programma inizierà a scaricare i pacchetti e successivamente ad installarli.


INIZIO RAPIDO

Breve introduzione all'utilizzo di QGIS, in particolare la guida farà riferimento alla versione 1.5 su Ubuntu 10.04, quindi potrebbero esserci minime differenze con altri sistemi operativi. La parte di guida che segue, non ha la pretesa di essere un manuale, ma solo una quick start per chi ha già un "infarinatura" di gis e QGIS. In rete esistono manuali molto professionali come quelli ufficiali, a cui si deve far in ogni caso riferimento per acquisire una conoscenza approfondita di tale software.

Interfaccia

Se si fa un confronto con GRASS, software a cui QGIS è strettamente legato, quello che subito salta agli occhi è la differenza dell'interfaccia. QGIS ha un interfaccia unificata intuitiva e di semplice utilizzo. Oltre al menu principale in alto e la barra delle informazioni (scala, coordinate...) in basso, si possono riconoscere tre sezioni ben distinte: in alto la sezione delle icone, con i comandi più utilizzati, sotto a sinistra si trova la finestra dei layer, dove si gestiscono i vari strati geografici (vettoriali, raster...) caricati nel programma, a destra si trova la finestra di visualizzazione dove si visualizza e si interagisce con i layer. Oltre a questi si possono attivare altre finestre come la panoramica e annulla/ripristina.

Progetto

Una buona regola quando si inizia un nuovo progetto è quella di impostarne subito le proprietà, come ad esempio il CRS (Coordinate di Riferimento Spaziale). Per far questo si deve accedere alle proprietà del progetto cliccando sull'icona in basso a destra (oppure da file-->proprietà progetto, oppure premento i tasti Ctrl+Shft+P), che si aprirà sul tab centrale (CRS). Se ad esempio stiamo lavorando in Toscana con delle CTR (carta tecnica regionale) dobbiamo impostare l' EPSG 3003 (Monte Mario / italy zone 1), per trovarlo o impostiamo il codice EPSG oppure facciamo un cerca per "nome" mettendo ad esempio "italy". Nel caso in cui si dovranno caricare file con CRS diverso da quello del progetto, è necessario spuntare in alto (sempre nel tab CRS di proprietà del progetto) l'opzione abilita la riproiezione al volo.

Nel tab "generale" si possono impostare varie proprietà, fra le quali ricordiamo il nome del progetto e la modalita di salvataggio dei percorsi, nel caso in cui si deve lavorare agli stessi dati, spostandoli da un pc ad un altro, conviene salvare tutti i layer e progetti dentro un albero di cartelle facilmente trasportabile ed impostare salva percorsi relativi. Oltre a questo si può impostare l'unità dei layer, se si è precedentemente definito il CRS è gia definito correttamente (ad esempio EPSG 3003 è in metri), la precisione e le proprietà della digitalizzazione.

E' inoltre possibile abilitare la digitalizzazione topologica durante la digitalizzazione, ad esempio se si disegnano due poligoni adiacenti con evitare la sovrapposizione sullo stesso layer, quando si andrà a muovere un vertice del lato in comune dei due poligoni, la superficie del secondo si adatterà al primo.

Infine nel caso di nuove digitalizzazione è importante impostare lo snap scegliendo la modalità, la tolleranza e il layer interessato oppure impostarlo predefinito per tutti layer da modifica-->opzioni di snap.

Layer

Qui per layer s'intende gli strati informativi geografici che possono essere in formato vettoriale come ad esempio uno shp esri, raster come un geotif, database spaziali come postgis e spatialite, tracce GPS come i GPX (solo con plugin) e servizi web OGC come WMS e WFS (solo con plugin) . Ognuno di questi può essere aggiunto mediante l'icona in alto oppure attraverso il menù a tendina "layer". Dallo stesso menù è possibile aggiungere un nuovo layer shp o spatialite od eliminare un layer caricato. Cliccando col tasto desto sul layer (vettoriale o database) caricato, oppure dal menù a tendina è possibile aprire la tabelle degli attributi, attivare o disattivare le modifiche, fare una query con la query builder, salvare l'intero vettoriale o una selezione anche in formato diverso, visualizzarne le proprietà e creare o aggiungerlo a dei gruppi di layer. Dal menù proprietà del layer è possibile cambiare la vestizione del dato con diverse simbologie, aggiungere delle etichette o diagrammi in base agli attributi visualizzare e modificare il CRS. Dal menù modififica-->Gestore stili è possibile creare degli stili di vestizione personalizzati (punti, linee, retini) oppure è possibile caricarne di già pronti (magari facendo o modificando con inkscape) da Modifica-->Opzioni-->Rendering e SVG in cui basta indicare la cartella dove sono presenti i file svg.

Visualizza

Dal menù Visualizza è possibile navigare nella mappa con i normali comandi di zoom (in e out, zoom su tutti i layer accesi, zoom sul layer selezionato e zoom sulla selezione, ultimo zoom) e pan. E' possibile selezionare o deselezionare gli elementi, visualizzarne le informazioni (della tabella, se è in editing e l'area), effettuare misure a schermo di segmenti, area, angoli (prima è necessario impostare il CRS), impostare dei segnalibri spaziali su cui poi fare zoom, inserire dei commenti sulla mappa e delle etichette in base ai campi dei layer. E' inoltre possibile attivare o disattivare i pannelli, le barre degli strumenti e la modalità schermo intero.

Digitalizzazione

Per iniziare la digitalizazione di un layer vettoriale è necessario premere attiva/disattiva modifica, da adesso si potrà aggiungere nuovi elementi (punti, linee, poligoni in base al layer), spostarli, selezionare i singoli nodi, spostarli aggiungerli o cancerllarli; copiare, tagliare o incollare un elemento selezionato, semplificarne la geometria, creare od eliminare un buco (poligoni), creare od eliminare un elemento staccato del precedente. E' anche possibile ridisegnare la forma di un elemento con modifica forma, spezzarlo o unirne le geometrie (merge). Attivando il plugin Freehand editing (paragrafo successivo) è possibile disegnare a mano libera. E' consigliabile salvare ogni tanto la digitalizzazione ed alla fine disattivare la modifica.

Plugin

I plugins sono una parte fondamentale di QGIS, grazie ai quali è possibile aggiungere caratteristiche e funzioni in maniera modulare. I plugins sono fra l'altro la prova lampante del lavoro e della partecipazione che sta dietro a questo progetto, infatti ogni settimana vengono aggiunti o aggiornati dei plugins direttamente dalla comunità che successivamente alla fase di test vengono inseriti direttamente nel codice di QGIS. Qgis ha infatti una struttura modulare in cui i plugins possono essere distinti in due sezioni: - i plugin ufficiali gia presenti nel programma come la georeferenziazione, il modulo grass, che si trovano in Plugins-->Gestione plugins e i quali basta spuntarli per attivarli. - i plugins esterni, ovvero quelli che devono essere prima scaricati da internet per essere utilizzati. Infatti da Plugins--Recupero plugin python si apre un gestore simili a synaptic per i sistemi debian con il quale è possibile scaricare, installare e disintallare i plugins dai repository esterni. Nella prima tab si ha la lista dei plugin il loro stato e descrizione, nel tab repository c'è la lista dei server, dove la prima volta conviene attivare aggiungi repository da terze parti, nel terzo tab è possibile impostare ogni quanto il programma aggiorna la lista dei plugins e quali deve mostrare (se solo quelli ufficiali, solo quelli stabili oppure tutti compresi quelli sperimentali). I plugins sono stati scritti in python e possono necessitare di installare alcuni pacchetti da Synaptic (o gestore pacchetti del sistema) per funzionare. Seguirà una breve lista e descrizione di alcuni (sono più di 150) dei plugins presenti in QGIS 1.7:

Plugin gia presenti

-CONVERTITORE DI DXF IN SHP

-GRASS con il quale è possibile lavorare su i mapset grass. Si aprirà una tabella con 10 tasti:

1-aprire un mapset grass gia esistente

2-creare un nuovo mapset con il wizard di QGIS

3-chiudere il mapset aprto

4-aggiungere un vettoriale grass alla vista

5-aggiungere un raster grass alla vista

6-creare un nuovo vettoriale grass

7-modificare il vettoriale grass (equivalente di v.edit)

8-aprire gli strumenti di grass, dal quale è possibile accedere alle funzioni di grass (non sono tutte presenti) sia da un albero dei moduli nella prima tab, sia da un semplice elenco con ricerca nella seconda tab. Nella terza tab, il browser, è invece possibile esplorare il contenuto dei mapset, con la relativa descrizione di ogni layer (risoluzione, formato,coordiante,valori e origine) ed è possibile aggiungerli alla vista,copiarli, rinominarli, cancellarli ed impostare la regione sul layer selezionato.

9-visualizza la regione attuale di grass (ovvero dove avvengono le elaborazioni di grass)

10-modifica la regione attuale di grass, con la quale basta disegnare un rettangolo con il cursore e dargli una risoluzione (N-S e E-O) e poi premere ok

-GDALTOOLS con cui è possibile fare alcune azioni dirette sui layer della vista, come convertire vettoriali in raster o viceversa, unire, convertire formati, ecc. e si utilizza da menù a tendina "raster".

-GEOREFERENZIATORE GDAL con il quale è possibile georeferenziare facilmente immagini.

-PLUGIN WFS per caricare layer wfs da server o database esterni, come ad esempio quelli del PCN

-PLUGIN INTERPOLAZIONE con il quale è possibile fare delle semplici modelli del terreno da vettoriali con punti quotati e curve di livello. Crea delle TIN o IDW (distanza inversa ponderata) ma per dei modelli piu accurati si consiglia l'uso di v.surf.rst

-PLUGIN ANALISI GEOMORFOLOGICA per elaborare mappe della pendenza, esposizione, indice di asperità e curvatura totale.

-QUICK PRINT per stampare una tavola al volo, completa di legenda.

-FTOOLS per la gestione e l'analisi dei layer vettoriali, come ad esempio funzioni geoprocessing (buffer, intersezione, unione, differenza,clip,dissolvenza).

Plugin da repository

-CADTOOLS permette di utilizzare alcune delle funzioni più comuni dei programmi cad come la digitalizzazione ortogonale, impostare la lunghezza e l'angolo.

-FREEHAND EDITING permette la digitalizzazione a "mano libera", una volta installato aggiungera un icona nel menu della digitalizzazione.

-MERGESHAPE fa il merge di shp, scegliendoli uno per uno oppure da una cartella intera.

-MULTIPLE COMPOSITION HELPER permette di esportare con un solo clic tutti i layout del progetto in immagini o pdf, è attivabile da Plugins-->Composer .

-PROFILE crea un immagine di output di un raster lungo un segmento. Ad esempio può essere utilizzato per disegnare profili altimetrici.

-SELECTPLUS aggiunge delle funzioni avanzate di selezione, come quella a mano libera, per raggio o invertita. si utilizza dal menù a tendina.

-SHADED RELIEF crea un modello delle ombre del terreno.

-TABLE MANAGER necessario per gestire le tabelle di shp, col quale si puo aggiungere o modificare colonne degli attributi.

-TRACE DIGITIZE permette la digitalizzazione "trace" ovvero attivando lo snap su un layer vettoriale è possibile ricalcarlo semplicemente passandoci sopra col mouse.

-ZIP LAYERS crea un file zip con tutti i layers (si possono anche selezionare) presenti nella vista.

Stampa

QGIS permette la gestione di più layout di stampa per ogni progetto. File-->Nuovo sistema di stampa (ctrl+P). Una volta aperta la finestra del layout si deve cliccare sull'icona aggiungi nuova mappa e disegnare con il cursore il rettangolo in cui verrà visualizzata. Allo stesso modo si possono aggiungere immagini, etichette, legende, forme di base, frecce e tabelle degli attributi. Ognuno di questi oggetti può essere spostato, raggruppato con altri, cambiato l'ordine di visualizzazione ed allineato. Ogni oggetto può essere gestito e modificato con il menù a destra, nel tab oggetto. Da qui è possibile cambiare la scale delle mappe, cambiare le forme degli oggetti, modificare le legende e i testi. Dal tab Generale è invece possibile impostare il formato della pagina, la risoluzione,e lo snapping fra gli oggetti. Attenzione nel caso usiate layer wms tipo ortofoto dei portali web come geoscopio, i layer caricati hanno una definizione massima (dai 75 ai 100 dpi) oltre la quale saranno visualizzati ma non stampati o esportati. La tavola potrà essere stampata direttamente, oppure esportata in rater (jpg, png..), pdf e svg.

INFINE ALCUNI CONSIGLI

Alcuni consigli per chi si trova per la prima volta nel mondo del software libero. Contrariamente a quanto avviene per il software closed, quando qualcosa "non funziona", imprecare non serve a niente, neanche a sfogarsi, in quanto il software libero può migliorare grazie a tutti noi. Ad esempio quando non si riesce a fare qualcosa, che con altri programmi facevamo facilmente, ricordiamoci che:


0- Solitamente il software libero non ha un costo di licenza, di acquisto o di assistenza, di conseguenza lo si utilizza a proprio rischio e pericolo. Quindi se stai lavorando con software libero senza spendere un euro non è il caso di denigrare il buon lavoro di altri.


1- Se non riesci in qualcosa, la prima cosa da fare è sicuramente leggere l'output di uscita dell'errore o meglio ancora il manuale del programma che è sempre installato con esso. Ad esempio per avere una rapido aiuto, basta digitare da terminale :

 qgis --help 


2- Come passo successivo si consiglia di fare una ricerca su internet. Contrariamente al software closed, nel software libero è più facile capire ed identificare il proprio problema e quindi cercare una soluzione su siti, forum o liste di discussione.


3- Come altra opzione nel caso di problemi, ma sopratutto per accrescere la propria cultura sul campo, è consigliabile iscriversi ad una mailing list (o lista di discussione), ovvero un servizio web gratis, in cui si può mandare una mail e questa viene indirizzata a tutti gli iscritti. In questo modo se si ha un problema lo si può porre ad un vasto pubblico in cui spesso sono iscritte persone che utilizzano il software da anni, ma anche gli stessi programmatori. Allo stesso modo una volta iscritti si può imparare dalle richieste degli altri, ma anche dare noi una mano a chi magari ha avuto un problema come il nostro. La mailing list italiana di riferimento per QGIS è quella di gfoss. Quando si ha un problema si consiglia di mandare una mail (in formato testo e non html) con la descrizione del problema, del sistema che usiamo (ad esempio Ubuntu 10.04 32 bit) e della versione di QGIS (es. 1.4).


4- Arrivati a questo punto si capisce come sia possibile ed importante partecipare attivamente alla diffusione software libero. Quindi il consiglio è quello di diventare parte attiva della comunità, promuovendo ed aiutando chi si avvicina per la prima volta a questo universo, ma anche aiutando i programmatori nella ricerca dei bug. Infatti contrariamente al mondo del software closed, qui chi trova errori nel sistema da un grande aiuto alla comunità e svolge un servizio molto richiesto. Tali bug è consigliabile comunicarli in mailing list cosi da avere un primo riscontro nel caso qualcuno ne fosse già a conoscenza.


5- Ultimo consiglio, se vi trovate difronte ad un bug noto non ancora risolto o semplicemente avete bisogno di una nuova funzione che ancora non esiste, potete voi stessi partecipare allo sviluppo del codice, oppure finanziare un programmatore che lo faccia per voi. Questo è possibile grazie al fatto che il software libero per esser tale deve rilasciare i propri sorgenti liberamente. Inoltre anche se non avete problemi o richieste particolari, potete comunque diventare finanziatori della ricerca e sviluppo di tale software oppure se non avete soldi potete per esempio partecipare alla traduzione dei manuali e dell'interfaccia di QGIS, o anche solo ampliare o correggere questa o altre guide online.


Questo vi fa capire quante siano le possibilità per rimboccarsi le maniche ed aiutare questa comunità!


INDIRIZZI UTILI

Specifici su QGIS

http://www.qgis.org/ portale di riferimento per QGIS

http://it.wikipedia.org/wiki/Quantum_GIS pagina wiki di descrizione del progetto

http://www.ing.unitn.it/~grass/docs/qgis-windows_install.pdf guida per l'installazione di qgis con supporto ecw tramite OSGeo4W su windows


Generali

http://grass.itc.it/ sito di riferimento su GRASS

http://www.rigacci.org/wiki/doku.php/tecnica/gps_cartografia_gis/download Ottimo sito di riferimento gis e dati liberi

http://www.openstreetmap.org/

http://www.gnu.org/software/libredwg/ http://savannah.gnu.org/projects/libredwg siti di riferimento per LibreDWG